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1 Introduction 

1.1 About FEFLOW 

FEFLOW (Finite Element subsurface FLOW and transport system) is an 
interactive groundwater modeling system for 

• three-dimensional and two-dimensional 

• regional and cross-sectional (horizontal, vertical or axisymmetric) 

• fluid density-coupled, also thermohaline, or uncoupled 

• variably saturated 

• transient or steady state 

• flow, groundwater age, mass and heat transport 

• reactive multi-species transport 

in subsurface water environments with or without one or multiple free sur-
faces. 

FEFLOW can be efficiently used to describe the spatial and temporal dis-
tribution and reactions of groundwater contaminants, to model geother-
mal processes, to estimate the duration and travel times of chemical species 
in aquifers, to plan and design remediation strategies and interception tech-
niques, and to assist in designing alternatives and effective monitoring 
schemes.  

Sophisticated interfaces to GIS and CAD data as well as simple text formats 
are provided.  

The option to use and develop user-specific plug-ins via the programming 
interface (Interface Manager IFM) allows the addition of external code or 
even external programs to FEFLOW. 

FEFLOW is available for WINDOWS systems as well as for different 
Linux distributions. 

Since its birth in 1979 FEFLOW has been continuously extended and 
improved. It is consistently maintained and further developed by a 
team of experts at DHI WASY. FEFLOW is used worldwide as a 
high-end groundwater modeling tool at universities, research 
institutes, govern-ment agencies and consulting companies.  

In 2013, the FEFLOW book - written by FEFLOW founder Prof. Hans-
Jörg Diersch - has been published by Springer. It represents a theoretical 
textbook and covers a wide range of physical and computational issues in 
the field of porous/fractured-media modeling. 

For additional information about FEFLOW please do not hesitate to con-
tact your local DHI office,  or have a look at the  FEFLOW web site 
http://www.feflow.com. 

1.2 Scope and Structure 

This exercise provides a step-by-step description of the setup, simulation, 
and post processing of a three-dimensional flow and mass transport model 
based on (simplified) real-world data, showing the philosopy and handling 
of the FEFLOW user interface.  

The introductory tutorial is not intended as an introduction to ground-
water modeling itself. Therefore, some background knowledge of ground-
water hydrology and modeling is required, otherwise respective literature 
should be consulted in parallel. 

The exercise covers the following work steps:  

• Definition of the basic model geometry 
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You can skip any 
of the steps in 
this exercise by 
loading already 

prepared files at certain 
stages.  These model 
stages are not necessarily 
ready to run.

• Generation of a 3D finite-element mesh 

• Setup of a transient transport model, including initial conditions, bound-
ary conditions and material properties 

• Import of GIS data and regionalization 

• Simulation run 

• Results visualization and post processing 

For additional information and other physical processes covered by FEFLOW, 
please refer to the FEFLOW help system in the main menu or by pressing 
the F1 key.  

1.3 Terms and Notations 

In addition to the verbal description of the required screen actions this 
exercise makes use of some icons. They are intended to assist in relating 
the written description to the graphical information provided by FEFLOW. 
The icons refer to the kind of setting to be done: 

 main menu 

 context menu 

 toolbar 

 panel 

 button 

 input box for text or numbers 

 switch toggle 

 radio button 

 checkbox 

All file names are printed in bold red, map names are printed in red italic 
and numbers or text to be entered by the user in bold green. Keyboard 
keys are referenced in <italic> style. All required files are available in the 
FEFLOW demo data. The  symbols indicates an intermediary stage 
where either a prepared file can be loaded to resume this exercise or - if 
working with a licensed copy of FEFLOW - it is recommended to save the 
model. Thus the exercise does not have to be done in one step even in demo 
mode. 

1.4 Requirements 

If not already done, please install the FEFLOW software including the 
demo data package. A license is not necessary to run this tutorial (FEFLOW 
can be run in demo mode). 

The latest version of FEFLOW can be downloaded from the website 
www.feflow.com. In case of any problems or additional questions please 
do not hesitate to contact the FEFLOW technical support 
 (mike.de@dhigroup.com ). 

1.5 Model Scenario 

A fictitious contaminant has been detected near the small town of 
Friedrichshagen, in the southeast of Berlin, Germany. An increasing con-
centration can be observed in two water supply wells. There are two poten-
tial sources of the contamination: The first are abandoned sewage fields 
close to a waste-water treatment plant located in an industrial area north-
east of town. The other possible source is an abandoned waste-disposal site 
further east. 

For following the 
exercise, the 
demo data files 
for FEFLOW 

have to be installed. The 
demo data installation pack-
age is available for down-
load from www.feflow.com.
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A three-dimensional groundwater flow and contaminant transport model 
is set up to evaluate the overall threat to groundwater quality, and to quan-
tify the potential pollution. First, the model domain needs to be defined. 
The town is surrounded by many natural flow boundaries, such as rivers 
and lakes. There are two small rivers that run north-south on either side 
of Friedrichshagen that can act as the eastern and western boundaries. The 
lake Müggelsee can limit the model domain to the south. The northern 
boundary is chosen along an northwest-southeast groundwater level con-
tour line north of the two potential  contamination sources. 

The geology of the study area is comprised of Quaternary sediments. The 
hydrogeologic system consists of two main aquifers separated by an aquitard. 
The top hydrostratigraphic unit is considered to be a sandy unconfined 
aquifer up to 7 meters thick. The second aquifer located below the clayey 
aquitard has an average thickness of approximately 30 meters.  

The northern part of the model area is primarily used for agriculture, 
whereas the southern portion is dominated by forest. In both parts, sig-
nificant urbanized areas exist. 
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2 Getting Started 

2.1 Starting FEFLOW 

On Windows Systems 

• Start FEFLOW 7.5 via the corresponding desktop icon or the startup 
menu entry. 

On Linux Systems 

• Type feflow75q in a console window and press <Enter> . 

If no FEFLOW license is available, FEFLOW can be set to demo mode via 
 Tools > License... In demo mode, loading and saving of files is lim-

ited to 2500 nodes. Specially prepared demo files provided with FEFLOW 
are an exception. Such files are available for all relevant steps of this exam-
ple so that the model setup can be interrupted and picked up again. 

2.2 FEFLOW 7.5 User Interface 

The user interface components are organized in a main menu, toolbars, 
panels, view windows, and dialogs. 

While the main menu is always visible, the other parts of the interface can 
be customized, adding or hiding particular toolbars and panels by using 
the menu command  View > Toolbars and  View > Panels, respec-
tively. Please keep in mind that not all panels and toolbars are displayed by 
default. Thus this exersice may require to access a function in a toolbar or 
panel that is not visible at that moment. The toolbar or panel has to be 
added then.  

During the work with FEFLOW models, view windows display a certain 
type of view on the model and its properties. There are different types of 

view windows: Supermesh view, Slice view, 3D view, Cross-Section view and 
Data-Trace  view. The availability of different functionality like toolbars 
depends on the currently active view type. 

View windows can be closed via the corresponding button in the view 
frame. New view windows can be opened by selecting  Window > New 
and choosing the respective view window type.  

The last type of user interface component relevant for the exercise are charts. 
Looking very similar to panels, they contain plots of time curves. Missing 
chart windows can be added to the user interface by opening  View > 
Charts from the menu and choosing the required chart type from the list. 

Last, but not least it might be worth to mention that all steps done in 
FEFLOW can be undone and redone via the corresponding toolbar but-
tons. There is no limit on the number of undo steps. 



• topography_rectified.tif (a georeferenced raster image of the model area 
for better orientation) 

• model_area.shp (a polygon map that contains several polygons denot-
ing the outer model boundary and embedded contamination areas) 

• contamination_sources.dxf (the footprint of the sewage fields and the 
waste disposal as polygons) 

• wells.shp (the positions of the wells) 
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Some of these maps will also be used for model parameterization later on. 
After import, the maps are shown in a list. The contamination source areas do 
not need to be converted into supermesh polygons, thus we uncheck  
Convert for the map contamination_sources and click  Finish. 

In the  Maps panel, all loaded maps are shown, by default sorted by their 
file type (see figure). A double click on the Geo-TIFF topography_rectified adds 
the georeferenced topographic map to the active Supermesh view window. 

Except for the maps contamination_sources and topography_rectified the maps 
are ESRI shape files. These vector files occupy their own branch in the tree, 
each with a default map layer. Double-click on all the Default layer entries to 
add the visualization layers of the shape files to the Supermesh view. 

Now have a closer look at a second panel, the   View Components panel. 
This panel lists the components that are currently plotted in the active view 
window.  

When loading the map layers to the view, the maps have also been added to 
the tree in the  View Components panel. 

In this exercise, 
different file
types are used 
as data source at 
the different 

stages of modelling to show 
the number of options. In 
practical projects, it may be 
preferred to store basic 
data in one file type, e.g., 
*.shp when using GIS.  

1_maps.mp4 

The exercise

3 Geometry

3.1 Maps and Model Bounds 

After opening FEFLOW, start a new model by using the menu command 
 File > New or the  New button in the  Standard toolbar. 

All necessary files for this exercise are provided with the FEFLOW Demo 

 Data package and are located in the project folder demo/exercise (by 
default in  

C:\Users\Public\Documents\DHI FEFLOW 
7.5.  

The map files are found in the subdirectory import+export. 

Click on  2D or layered 3D mesh and press  Next. Pick the option 
 Supermesh import from maps and click  Next. On the upcoming 

page of the wizard, press the button for adding maps and load all the fol-
lowing maps at once (by holding <Ctrl> on the keyboard) to ensure that 
FEFLOW uses the bounding box of all the maps to define the initial domain 
bounds. You may have to select All Maps in the Files of Type selector at the 
bottom of the dialog. 

 The particular map files that are needed now are: 

workflows are 
also available as 
video screen-

casts on the FEFLOW 
installation USB drive and 
in the FEFLOW channel on 
YouTube.  
The video symbol and the 
file name indicate the 
respective video for the fol-
lowing workflow. The first 
video starts here.  
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The drawing order of maps can be modified by dragging them with the 
mouse to another position in the tree (this might become necessary as the 
model area polygon may overlay the polygons of the mass sources). The 
topmost map is drawn on top.  

To switch a map on and off, the checkbox in front of the map name can 
be checked/unchecked. If checking/unchecking the checkbox of an entire 
branch all the maps in this branch become visible/invisible at the same time.  

The topographic map has mainly been loaded for providing a regional con-
text. For more clarity, it can be switched off before starting with the fol-
lowing operations. Make sure that the other maps are visible. 

3.2 Supermesh  

In the simplest case, the supermesh contains a definition of the outer model 
boundary. In addition, geometrical features such as the position of pump-
ing wells, the limits of areas with different properties or the courses of rivers 
can be included to be considered for the generation of the finite-element 
mesh. Additionally, the polygons, lines and points specified in the super-
mesh can be used later on to assign boundary conditions or material prop-
erties. 

As mentioned above, a supermesh may contain three types of features: 

• polygons 

• lines

• points 

At least one polygon has to be created to define the model area boundaries. 

The editing tools for the supermesh are found in the  Mesh Editor 
toolbar: 

By having imported the maps with the checkbox for conversion set, the 
geometries inthe corresponding maps have been converted into supermesh 
polygons and points automatically. Thus we do not have to manually edit 
the supermesh here. 

Both polygons and points are shown in the Supermesh view. 

exercise_fri1.smh 

3.3 Finite element mesh 

Once the outer boundary and other geometrical constraints have been 
defined in the supermesh, the finite-element mesh can be generated.  

All necessary tools can be found in the  Meshing panel. 
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For this example, choose the mesh generation algorithm  Gridbuilder. 
Click  Generate Mesh to start mesh generation. 

A new Slice view is automatically opened, depicting the resulting finite-ele-
ment mesh. 

For our purpose, especially for the simulation of contaminant transport, 
this initially generated mesh does not seem to be appropriate. A finer spa-
tial resolution is required. 

Activate the Supermesh view again and note that the  Supermesh tool-
bar become visible again. 

In the section From Supermesh Elements in the  Meshing panel, click 
on Supermesh, and enter  6000 as Proposed Elements. Click  on 

 Generate Mesh again. The finite-element mesh in the Slice view is 
updated, showing a finer discretization now.  

Local refinement 

At the pumping wells steep hydraulic gradients are expected at the center 
of the well cone. To better represent these, a locally fine discretization is 
desirable. 

Click on  Generator Properties in the  Meshing panel if the gener-
ator properties are not yet shown.  

To obtain a refinement around the well locations, set the  Point refine-
ment value to 10. 

Click  Generate Mesh one last time and check the mesh for changes.  

exercise_fri1.fem 

2_supermesh.mp4 
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3.4 Expansion to 3D 

Up to this point we have worked on the model seen in top view, not con-
sidering the vertical direction. Starting from this 2D geometry, a 3D model 
consisting of several layers is set up. 

The actual elevation of the layer tops and bottoms is derived by an inter-
polation based on map data (point-based data). 

For this example, three geological layers are considered for the model. An 
upper aquifer is limited by the ground surface on top and by an aquitard 
on bottom. A second aquifer is situated below the aquitard, underlain by 
a low permeable unit of unknown thickness. This underlying stratigraphic 
layer is assumed to be impervious and is not part of the simulation. 

When using a layered approach, FEFLOW distinguishes between layers 
and slices in 3D. Layers are three-dimensional bodies that typically repre-
sent geological formations like aquifers and aquitards. The interfaces between 
layers, as well as the top and bottom model boundaries, are called slices. 

In a first step, the numbers of layers  and slices are defined. The actual 
stratigraphic data are applied in a separate step afterwards. 

Introductory Tutorial

Initial 3D Setup 

Open  Edit > 3D Layer Configuration.  

On the left side of the dialog, the current slices are shown (Slice 1 and Slice 
2), corresponding to one single layer with the default top and bottom ele-
vations of 0 m, 1 m resp. We add two more slices by clicking on Slice 1 and 
then on ICON Insert Slice(s) above. In the upcoming dialog, increase the 
Number of slices to  2 and click  OK. 

The elevations of the slices are not relevant at this stage. 
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Click on  OK to apply the settings and to exit the dialog. After finis-
hing the basic layer configuration of the 3D model, a 3D view automa-
tically opens. This view shows the actual 3D geometry of the model, now 
containing 4 planar slices with a distance of 1 m each. The 3D view back-
ground by default is set to black. To achieve better visibility in print, for 
all images in this exercise a white view background has been applied. 

 exercise_fri2.fem 

Elevation Data 

This raw geometry will be formed into its real shape by regionalizing ele-
vation data contained in map files. 

The basic data have been derived from a DEM and from borehole logs, and 
have been combined into an Excel file (*.xlsx) with four columns: X, Y, Ele, 
and Slice. Such a file can only be edited  in spreadsheet software such as 
Microsoft Excel or Open Office / LibreOffice. Containing the target slice 
number as a point attribute, the file can be used as the basis for regional-
ization of elevations for all slices at once. The elevations are given in meters 

ASL.

The file has to be loaded as a map before its attribute data can be used as 
the basis for interpolation. In to the  Maps panel click on  Filter 
and use Add Map(s)... to load elevations.xlsx. It is not necessary to visualize 
the map in the view. 

The usage of Excel files requires the installation of a licensed copy of 
Microsoft Excel. On Linux systems or where Excel is not installed, please 
load elevations.dat instead of the Excel file. 

As a next step, the attribute values of the data file need to be associated 
with (linked to) their respective FEFLOW parameter, in this case with the 
elevation. In order to do this, open the context menu of the map elevations 
with a right click and choose  Link to Parameter(s)…. 

Zooming func-
tions can be used 
at any time. 
Press and hold 

the right mouse button, 
move the mouse up/down). 
Pan by pressing and hold-
ing the mouse wheel and 
moving the mouse to any 
direction. Also the mouse 
wheel may be used for 

Besides refine-
ment at points or  
polygon borders, 
FEFLOW also 

provides the means to edit 
the desired relative mesh 
density on a polygon-by-
polygon basis. 
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Besides linking the attribute field to the model properties, a number of set-
tings has to be done to ensure appropriate regionalization when import-
ing the map data to the nodal values. 

By default, FEFLOW expects elevation data to be in the unit meters, which 
is correct in this case. 

Data are regionalized by applying two-dimensional interpolation. To sep-
arate data for the different slices, select Field containing slice number in 
Node/Slice Selection. In the next line, choose the attribute Slice as Field con-
taining slice number (see image). 

From the dropdown menu for Data Regionalization Method in the lower 
part of the dialog, choose the  Akima method. As the properties, set: 

• Interpolation type:  Linear 

Introductory Tutorial

On the left-hand side of the dialog, the available attributes of the map are 
listed. Select the entry Ele with a mouse click. 

On the right-hand side, a tree view contains all available FEFLOW param-
eters that can be associated with the data. In this tree, open the Process 
 Variables > Elevation branch and click on Elevation. 

Click on  Add Link to establish a connection between the values in the 
map and the elevation data, or - alternatively - double click on Elevation to 
set the link.  

3_3D_geometry.mp4 
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• Neighbors:  3. Only the three map points that are closest to a mesh 
node are used for the interpolation. 

• Over-/Under Shooting:  0. Thus the resulting values may not exceed 
the range of input values. 

Click on  OK to apply these settings and to close the dialog. 

Elevation data assignment 

Click into the 3D view to bring it to front. Make sure to have the  Rotate 
tool in the  View toolbar activated. Rotation, panning, and zooming 
can be easily performed using the mouse: 

• Left mouse button: rotate the model around its center of gravity 

• Center mouse button (mouse wheel): pan the model 

• Right mouse button: zoom (in/out) 

As the model has a rather small vertical extent compared to its horizontal 
dimensions, the (vertical) z-axis should be exaggerated. 

This can be done in the  Navigation panel (  View > Panels). 

Click on the tab Projection and move the Scaling slider bar upwards until 
you have achieved a convenient view on the 3D model. Alternatively, the 
<Shift> key in combination with the mouse wheel can be used to change 
the stretch factor for the active 3D view. 

To finally assign the elevation data by regionalization from map data to the 
selected nodes, two more steps are required: 

• In the  Maps panel, open the branch Maps > ASCII Table Files > 
elevation. Under Linked Attributes, double-click on Ele -> Elevation.

• Hereby, in the  Editor toolbar, the map elevation is automatically 
set as data source in the input box and the model property Elevation is 
activated as parameter. Note that also Elevation has been chosen in the 

 Data panel and is now shown in bold letters. 

• Click on  Select All in the  Selection toolbar.

• Click  Assign in the  Editor toolbar to apply the new elevation 
data to all nodes. 
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In the 3D view the node elevations are immediately updated. 

Click on  Clear Selection in the  Selection toolbar.

The result looks as shown in the figure below. Probably the Scaling has to 
be adjusted again (  Navigation panel > Projection tab or <Shift> - mouse 
wheel) to account for the changed vertical extent. 

 exercise_fri3.fem 

4 Problem settings 

FEFLOW provides the means to simulate a number of different physical 
processes in different spatial and temporal dimensions, ranging from sim-
ple 2D steady-state flow models to transient, unsaturated, density-coupled 
reactive transport models. As the input parameters depend on the model 
type, the general problem settings are typically done in the beginning. 

Go to  Edit > Problem Settings to open the Problem Settings dialog, 
where all general settings related to the current model are done. 

Introductory Tutorial
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All these settings are organized in thematic pages controlled by a tree view 
on the left-hand side of the dialog. 

Problem class 

The principal type of the FEFLOW model is defined on the Problem Class 
page.  

Below the Scenario description (which is not mandatory to be modified) 
one of two general types of problems - saturated media and unsatu-
rated/variably saturated media - is chosen. 

By default Standard (saturated) groundwater flow equation is selected, apply-
ing Darcy’s equation. Though this option is selected, the model is able to 
account for phreatic conditions.  

The second option - Richards’ equation (unsaturated or variably saturated 
media) - would lead to Richards’ equation being applied, accounting for 
both saturated and unsaturated conditions within one model.  

In this particular case, it is not expected that considering the unsatu-
rated/variably saturated zone would change the model result to an extent 
that would justify the additional effort for the solution. 

Keep the default setting (Standard groundwater-flow equation) for this exer-
cise. 

On the same page, also other Problem class settings are done. Besides choos-
ing between transient and steady-state conditions, it is also possible to add 
mass, groundwater age or heat transport processes to the flow simulation. 

However, activating the transport option now would increase the com-
plexity to an extent that is not necessary at this stage. Thus we first focus 
on the flow model and add mass transport at a later stage. 

The flow model is to be run for steady-state conditions, so switch to 
 Steady.  

Click on  Apply to apply the changes. 



Free Surface 

The first aquifer in the simulation area is known to be unconfined, so a 
phreatic water table is to be simulated. For this example, an approxima-
tion of the phreatic level by applying a pseudo-unsaturated technology is 
chosen. Hereby, a reduced conductivity is applied during the simulation 
to model layers if they are located above the water table. For more infor-
mation on the handling of free surfaces in 3D models, please refer to the 
help system  . 

The settings for unconfined conditions are located on the Free Surface page. 
First of all, switch to  Unconfined aquifer(s). In the Status column, open 
the drop down list of Slice 1 and choose the option  Phreatic.  

For the slices 2 and 3 keep the option  Dependent (the status of the 
bottom slice 4 is fixed and cannot be changed). 

Finally, set the Residual water depth for unconfined layers to a value of 0.05 
m, hereby increasing the residual conductivity of dry elements for adding 
additional stability.  

Close the dialog by clicking  Apply and  OK. 

exercise_fri4.fem 

5 Model Parameters 

In the following sections, the physical properties of the study area are 
applied to the finite-element model. 

The respective parameters are found in the   Data panel. The param-
eters are organized in the following main branches in the tree view: 

• Geometry 

17 IIntroductory Tutorial

Introductory Tutorial
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• Process Variables 

• Boundary Conditions 

• Material Properties 

• Auxiliary Data 

• User Data 

• Discrete Features 

5.1 Boundary conditions 

To calculate the hydraulic head distribution between the upstream and 
downstream boundary, appropriate boundary conditions are applied. For 
the sake of simplicity, they will be kept in a rather simple way: 

• Southern border: The lake Müggelsee completely controls the head 
along the southern boundary. The lake water level of 32.1 m is used as 
the value for a 1st kind (Dirichlet) hydraulic-head boundary condition. 

• Northern border: As there is no natural boundary condition like a water 
divide close to the boundary, a head contour line will be used instead 
(hydraulich head = 46 m). 

• Western and eastern border: Two small rivers (the Fredersdorfer 
Mühlenfließ and the Neuenhagener Mühlenfließ) form the boundaries 
at the western and eastern limits of the model. As they roughly follow 
the groundwater flow direction, we assume these heavily clogged creeks 
to represent boundary streamlines. No exchange of water is expected 
over this boundary and therefore a no-flow boundary condition is assumed. 

• Finally, two wells, with a pumping rate of 900 m3/d and 1,000 m3/d, 
respectively, are located in the southern part of the model. These rep-
resent a number of large well fields in reality. 

The hydraulic head boundary conditions are entered manually, while the 
wells are derived from a map.  

Manual editing is often easier if being done in a 2D view. Thus switch to 
the Slice view. If you have accidentally closed it, a new view can be opened 
via  Window > Slice view.  

Slice view 

This view type always shows a single slice or layer. Browsing between the 
slices is easiest by hitting the <Pg Up> and <Pg Down> keys, respectively. 
Alternatively, the layer/slice to be seen in the view can be directly selected 
in the  Spatial Units panel. 

The recommended tool for navigation in the Slice view is the  Pan tool 
in the  View toolbar. The mouse buttons are associated with the fol-
lowing functions: 

• Left and center mouse button: pan

• Right mouse button: zoom (in/out) 

• Mouse wheel: zoom (in/out) in steps 

Northern Boundary 

Zoom to the northern boundary. 

For the Slice view, the  Selection toolbar provides additional tools for 
selecting nodes compared to the 3D view. Choose  Select Nodes Along 
a Border. 

4_problem_settings.mp4 
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Go to the  Data panel and double-click on Boundary Conditions (BC) 
> Fluid flow > Hydraulic-head BC, the type of boundary condition to be 
applied. 

To manually assign a hydraulic-head boundary condition make sure that 
the Assign Values method is active in the  Editor toolbar (see figure). 
If not, open the context menu by a right click on the symbol in the input 
box and choose  Assign 
Values.

Introductory Tutorial

Having this tool selected, click on the westernmost node of the boundary 
and hold down the left mouse button, move the mouse cursor to the east-
ernmost node and release the button. The nodes of the northern border 
are highlighted as yellow points. The selection is shown in the 3D view 
simultaneously. 

Next, the selection is extended to the other three slices of the model. A 
time-saving way to do this is the application of the  Copy Selection to 
Layers/Slices tool. Start the tool and select all slices in the upcoming dialog 
(manually or by hitting <Strg>-<A>). Click on  OK. 

Bring up the 3D view and ensure that indeed all nodes at the northern 
boundary are selected.  
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Enter  46 m in the input box of the  Editor toolbar and click on 
the Assign 
button.

Blue circles appear around the selected nodes to indicate the Hydraulic-
head BC. While having the 3D view active, double-click on Hydraulic-head BC 
in the  Data panel to also show the boundary conditions in 3D.  

The values of the boundary condition can be checked using the inspection 
tool, which is activated by clicking on  Inspect nodal/elemental values in 
the  Inspection toolbar. Move the hair-cross to a node with a bound-
ary condition. The values of all properties currently visible in the active 
view are shown in the  Inspection panel. 

The inspection tool can be closed by hitting <Esc>  or by activating another 
tool (e.g., the default tool  Rotate) in the  View toolbar. 

After defining the boundary condition at the northern boundary, we store 
the current node selection for later use: 

Open the context menu of the  Spatial Units panel and choose  Store 
Current Selection. 

In the Node Selection dialog, change the name to  Northern Boundary 
and click  OK. The stored selection appears in the  Selections 
panel. Click on  Clear selection. 

Southern Boundary 

The assignment of boundary conditions along the southern boundary is 
done in the same way: 

• In the Slice view, zoom/pan to the southern border. 

•  Select nodes along a border. 

•  Copy selection to all slices. 

• Switch to the 3D view and check that the selection is set correctly. 

5_flow_bcs.mp4 
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• Make sure that  Hydraulic-head BC in the  Data panel is still 
active.

• Type  32.1 m in the input box of the  Editor toolbar and click 
 Assign. 

• Store the selection for later use, naming it  Southern Boundary. 

•  Clear selection . 

 exercise_fri5.fem 

Remaining outer boundaries 

At nodes without an explicit boundary condition set, FEFLOW automat-
ically applies a no-flow condition. Therefore, no further action is required 
for the western, eastern, top and bottom model boundaries, which are 
assumed to be impervious except for groundwater recharge to be added 
later. 

Pumping wells 

The wells are to be set in the southern part of the study area based on the 
map wells. They are assumed to be screened throughout the whole depth 
of the model. 

This kind of well, which stretches along a number  of layers, is called a mul-
tilayer well. Multilayer wells are assigned along vertical element edges. Nodes 
along these edge selections are connected automatically by a high-con-
ductive finite element that mimics the borehole. 

Several parameters are necessary to assign a multi-layer well, including the 
pumping rate, the radius of the well and elevation of the top and bottom 
end of the screen. 

While it is also possible to manually enter these values, it is more conve-
nient to import them from a map.  

The wells map contains attribute data that need to be associated with (linked 
to) their respective FEFLOW parameter. In order to do this, open the con-
text menu of the map wells (in the  Maps panel) with a right click and 
choose  Link to Parameter… to open the Parameter Association dialog. 

On the left-hand side of the dialog, you see the available data of the map.  

The attribute RATE relates to the abstraction rate of the well, select it with 
a mouse click. 

On the right-hand side, open the Boundary Conditions > Fluid Flow > 
Multilayer Well branch and click on Type > Rate. 

Click on  Add Link to establish a connection between the values in the 
map and the Multilayer well or double click on Rate to set the link.  

Introductory Tutorial
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Repeat these steps for the attribute fields  

• RADIUS  (link to Radius) 

• SCREENTOP (link to Top elevation) 

• SCREENBOTT (link to Bottom Elevation) 

• NAME (link to Name). 

Each well will be created along that edge that is closest to its correspond-
ing data point, but still within a user-defined search radius (snap distance). 
The Snap Distance should be small but greater than zero. Enter  0.01 
meters in the input field. Click  OK to close the dialog. 

The actual assignment is done in a similar way already performed while 
importing the elevation data. 

• In the  Maps panel, open the branch Maps > ESRI Shape Files > 
wells. In Linked Attributes, double-click on <multiple>->Multilayer Well.

• Click on   Select All in the  Selection toolbar. 

• Click on  Assign in the  Editor toolbar. Even though all edges 
in the model have been selected, the multilayer wells will be assigned 
each to the closest edges only.  Clear the selection.

 exercise_fri6.fem 

Finally check all boundary conditions you have set. 

Go to the 3D view. Make sure that Domain is selected in the  Spatial Units 
panel. Double-click on Boundary Conditions (BC) > Fluid flow in the 

 Data panel. All boundary conditions are shown in the view. Uncheck 
the checkbox of Geometry >  Faces in the  View Components 
panel to see into the domain. 

Blue circles are shown on the northern and southern border, and four red 
symbols for each well. 
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 exercise_fri7.fem 

5.2 Material properties 

Top Aquifer (Layer 1) 

In the top aquifer, the hydraulic conductivity, the porosity as well as the 
groundwater recharge are to be set. 

Although groundwater recharge from a mathematical point of view is rather 
a boundary condition, it is handled as a material property in FEFLOW. In 
a 3D model, the respective parameter to be set is In/Outflow on top/bottom. 

The input procedures for material properties are completely analogous to 
the ones for the boundary conditions; material properties however are 
assigned to elements instead of nodes: 

• Go to the 3D view. 

• Reactivate the checkbox of Geometry >  Faces in the 
 View Components panel. 

• Activate Material Properties > Fluid Flow > In/Outflow on top/bottom in 
the  Data panel with a double-click. 

• Choose the  Select Complete Layer/Slice tool (in the dropdown selec-
tor on the left of the toolbar) in the  Selection toolbar and select 
all elements in the top layer by clicking on it. 

• In the  Data panel, right-click on In/Outflow on top/bottom  and 
choose  Set Unit > mm/a from the context menu. 

• Input a value of  195 mm/a into the box in the  Editor tool-
barand hit <Enter>. 

The porosity is applied to the same selection: 

• Activate Drain/Fillable Porosity in the  Data panel with a double-
click. 

• Input a value of  0.1 and hit <Enter>. 

The hydraulic conductivity will be assigned by interpolating data from field 
samples.  

• Add the map conduc2d.trp to the  Maps panel (  Add map(s)). 
This file contains point-based conductivity values for the top aquifer 
in the unit 10-4 m/s.

• Associate (  Link to Parameter…) the attribute column Value to the 
FEFLOW parameter K_xx. K_yy and K_zz will be calculated from K_xx 
and assigned later).

• Choose  10-4 m/s as Source data unit 

• As a regionalization method, choose  Akima,  Linear, with 
Neighbors  3 and  0 % Over-/Under Shooting. Activate the 
checkbox  Logarithmic. Close the dialog with  OK. 

• Double-click on Conductivity > K_xx in the  Data panel. 
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Lower aquifer (Layer 3) 

Repeat the same steps as for layer 2: 

•  Clear selection and select the elements in the third layer applying 
 Select Complete Layer/Slice again. 

• Choose  Assign Multiple...  from the context menu of Material 
Properties > Fluid Flow. 

• Enter  2e-4 m/s for K_xx. 

• Enter  0.1 for the Drain-/fillable porosity. 

•  Uncheck all other properties. 

• Click the  OK button to finalize the assignment. 

•  Clear selection. 

 exercise_fri9.fem 

Anisotropic hydraulic conductivity 

While K_xx has been assigned already, K_yy and K_zz will be derived from 
K_xx. 

K_yy is equal to K_xx, it will be assigned using a simple copy&paste pro-
cedure: 

•  Select All elements in the 3D view. 

• Choose  Copy...  from the context menu of Material Properties > 
Fluid Flow > Conductivity > K_xx.

• Double-click Material Properties > Fluid Flow > Conductivity > K_yy. 

• Choose   Paste...  from the context menu of Material Properties > 
Fluid Flow > Conductivity > K_yy. 

If the top layer is no longer selected, choose the  Select Complete Layer/Slice 
tool in the  Selection toolbar and select it. 

• In the  Maps panel, double-click on Linked Attributes > Value -> 
K_xx.

• To finally assign the conductivity values, click the  Assign button 
in the  Editor toolbar. 

 exercise_fri8.fem 

Aquitard (Layer 2) 

In the second layer, we only need to assign constant values for the con-
ductivity and drain-/fillable porosity.  

•  Clear selection and select the elements in the second layer apply-
ing  Select Complete Layer/Slice again. 

A very efficient way to assign multiple model properties is by right-click-
ing on Material Properties > Fluid Flow in the  Data panel and choos-
ing   Assign Multiple... from the context menu. 

In the following dialog,  

• Enter  1e-6 m/s for K_xx (including the unit!). 

• Enter  0.15 for the Drain-/fillable porosity 

•  Uncheck all other properties. 

• Click  OK to finalize the assignment. 
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Besides manual assignment and data import, FEFLOW allows to calculate 
model properties from mathematical expressions. This will be used for the 
vertical conductivity K_zz, which is assumed to be 10% of the lateral con-
ductivity K_xx. 

• Double-click on Material Properties > Fluid Flow > Conductivity > K_zz. 

• Switch to the  Expression input method by clicking on the icon in 
the input box of the  Editor toolbar or by right-clicking into the 
box and selecting from the drop-down list. Then double click on Current 
Expression. The Expression Editor opens. 

The Expression Editor is a tool to create arbitrary mathematical expressions 
for various purposes. At the top of the dialog several toolbars provide basic 
mathematical operations. On the right hand side there is a list of all model 
parameters that can be used within the expression. All operations and 
parameters can be added to the expession by a double click, or by directly 
typing them into the expression using the keyboard. 

For this particular operation, select and delete the word current on the right 
hand side of the equality sign. Afterwards, double-click on Material Properties 
> Fluid Flow > Conductivity > CONDX in the list on the right to insert it 
into the expression. Afterwards, click on the multiplication symbol in the 
toolbar on the top and finally type 0.1 on your keyboard. The resulting 
expression (see figure) calculates the vertical conductivity as 10% of the 
horizontal conductivity. Afterwards, press  Close. 

To finally assign the new values, click the  Assign button in the 
Editor toolbar. 

 Clear selection. 

 exercise_fri10.fem 

Reference Field Data 

To be able to compare the computed groundwater levels to measurements, 
a couple of observation points will be loaded into the model. 

Go to the  Maps panel and use the button (  Add Map(s)...) to add 
observation_wells.dat to the list of loaded maps. It is not necessary to visu-
alize the map in the view. 

Open the Slice view again if it has been closed. 

Right-click on the map entry in the  Maps panel and choose
Convert to ... > Observation Points from the context menu. The map file 
contains information about the location, slice number and measured 
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hydraulic head in the observation well. As default headers are used in this 
example file, the association of attributes to the properties of the observa-
tion points works automatically and no changes need to be done in the 
upcoming dialog. Click the  OK button to proceed. 

The now imported observation wells can be shown by a double-click on 
Observation Points in the  Entities panel. 

 exercise_fri11.fem 

6 Simulation 

The flow part of the flow and transport model is complete. By running the 
steady-state model, a hydraulic head distribution will be computed that will 
also act as initial condition for the following transient simulation. 

In case that FEFLOW is run in licensed mode, save the model to be able 
to return to the initial properties later! If running FEFLOW in demo mode, 
this model cannot be saved as the number of nodes per slice exceeds the 
allowed maximum of 500. Please use the prepared file exercise_fri11.fem in 
this case. 

Starting the simulation 

To run the simulation, click  Start in the  Simulator toolbar.  

As the model is unconfined, the resulting nonlinear equation system needs 
solved iteratively, taking into account that the saturated thickness of uncon-
fined layers depends on the actual solution for hydraulic head. The Error 
Norm History chart provides information about the remaining error in each 

simulation iteration. The simulation stops after eight iterations, the error 
reaching values below the defined error criterion. 

During and after the simulation, all visualization tools in FEFLOW can be 
used to monitor and postprocess the simulation results. 

Make sure to select Domain in the  Spatial Units panel. Go to the 
 Data panel and double-click on Process Variables > Fluid Flow > Hydraulic 

head for visualization of the resulting hydraulic head distribution. 

In addition, go to the  Spatial Units panel and select (single click) Model 
Locations > Observation Points. Afterwards, double click Process Variables 
> Fluid Flow > Hydraulic head in the  Data panel. 

In the  View Components panel, check both boxes  for Hydraulic 
Head > Fringes and  Isolines and uncheck Hydraulic Head >  Continous. 
To achieve better visibility in print, the element edges have been removed 
in the figure. 

Make sure to select Domain in the  Spatial Units panel afterwards. 

7_material_properties_I.mp4 
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Scene Library 

In the Slice View, chose   Create Scene from Window. This stores a 
copy of the current view and all its settings in the  Scene Library panel, 
in order to use it later for restoring the view. 

 exercise_fri12.fem  

In case of loading the file, run the simulation before proceeding. 

Budget 

To check whether the model indeed has reached the steady state, the over-
all water balance is calculated. The  Rate-Budget panel provides the 
means for this. 

If it has been closed accidentally, open the  Rate-Budget panel via 
 View > Panels > Rate-Budget Panel. 

Check the  Active checkbox to activate the budget calculation. The 
budgeting is turned off by default as it can cause significant computational 
effort, especially when being done at each time step during a transient sim-
ulation run. 

The budget shows inflows in green, outflows in red for the different boun-
dary condition types,  the areal sources and sinks (groundwater recharge) 
and - for transient models only - the storage capture or release. The 
Imbalance value shows the numerical error. it is sufficiently small to accept 
the solution as steady state. 

Streamlines 

One way to visualize the flow field is the plotting of streamlines. 

Streamlines are calculated by tracking the path of virtual particles that are 
released („seeded“) at certain starting points. In our case, multiple stream-
lines are released from around the nodes along the well screens. The ran-
dom-walk method is used to add a diffusive/dispersive component to the 
particle tracking, hereby accounting for uncertainty. 

First, a selection is created containing all nodes along the well screens. 

Go to the 3D view. 

In the  Data panel, right-click on Boundary Conditions > Fluid Flow > 
Multilayer Well and choose  Convert Parameter to > 3D Nodal Selection 
from the context menu. To save this selection, go to the  Spatial Units 
panel and right-click to open the context menu. 

Introductory Tutorial
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From the result it can be seen that the western well is certainly influenced 
by the sewage fields. The eastern well seems to be reached by contamina-
tion from neither source. . 

For more detailed analysis, a transport model seems useful. 

Reactivate the checkbox of Geometry >  Faces in the  View 
Components panel before proceeding. 

7 Flow and Transport Model 

To exit simulation mode in order to apply changes to the model, click 
 Stop in the  Simulator toolbar. 

When the flow model has been run, the process variable Hydraulic head 
has changed. After the run, it does not contain the initial conditions any 
more, but the final results. 

In our case these will be used as the initial condition for the transient flow 
model. 
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Choose  Store Current Selection and give the saved selection the name 
 Wells. 

Now, uncheck Geometry >  Faces in the  View Components panel 
to be able to see inside the model domain. 

In the  Selections panel, click on Node Selections > Wells. 

In the  Data panel, double-click on Process Variables > Fluid Flow > 
Random-Walks > Backward. 

In the  View Components panel, right-click on Travel time, backward 
streamlines (RWT) seeded@wells and choose  Properties 

from the context menu. 

In the now opened  Properties panel, enter 100 m as the Radius, press 
<Enter> and click  Apply. Still in the same panel, right-click on the 

color scale on the left and choose  Presets... > 
Rainbow. 

Finally, activate the checkmark  Travel time, backward streamline RWT 
seeded@wells > Legs in the  View Components panel. 

As a result, the random-walk tracks are shown in the 3D view. The color 
scale displays the travel time along these pathways. 
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 exercise_fri13.fem  

To obtain the correct status, run the simulation before proceeding and 
click on  Stop. 

7.1 Problem settings 

Problem class 

From the preliminary streamline analysis based on the results of the flow 
model it cannot be excluded that the contamination sources are located 
within the capture zone of the production wells. To be able to provide more 
quantitative estimations, the model is extended to a flow and mass trans-
port model. 

Introductory Tutorial

To change the problem class, go to  Edit > Problem Settings to open 
the Problem Settings dialog. In Problem Class, Include transport of...  Mass 
and choose the  Transient option for both the Fluid Flow and the 
Transport simulation. 

Confirm with  Apply. 
9_observation_points.mp4 

10_flow_simulation.mp4 

It is recom-
mended to save 
the file before 
starting the simu-

lation (if working with a 
license). During the simu-
lation, the process variables 
will change and you would 
lose the initial conditions of 
the model.
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Time stepping 

In a transient model temporal discretization has to be defined. The corre-
sponding settings can be found on the Simulation-Time Control page. 

By default, FEFLOW uses an automatic time-step control scheme. Hereby, 
an appropriate time-step length is determined internally by monitoring the 
changes in the primary variables (hydraulic head and concentration).  

Enter a value of  7300 days in the Final Time input box.  

Click on  Apply and  OK. 

 exercise_fri14.fem 

7.2 Initial conditions 

Click on Domain in the  Entities panel. 

Switch to the 3D view. Double-click on Process Variables > Mass transport 
> Mass Concentration in the  Data panel. The 3D view shows the default 
initial concentration of 0 mg/l, representing fresh water. No changes are 
necessary for the background concentration. 

Contamination sources 

The contamination sources are represented by a higher initial concentra-
tion in the areas of the sewage fields and the landfill within the first aquifer. 

First, a selection of the nodes belonging to the contamination source is 
needed.  

Go to the Slice view and browse to Slice 1. Double-click on Process Variables 
> Mass transport > Mass Concentration in the  Data panel. In the 

 Maps panel, activate (double-click) the map contamination_sources. 
Choose the option  Select by Map Polygon from the dropdown selec-
tor of the  Selection toolbar. Make sure the Snap distance is set to 

0 m in the  Snap-Distance toolbar. Click  Select by All Map 
Geometries in the  Selection toolbar. 

The contamination in both areas is found to reach down to the top of the 
aquitard. Use  Copy Selection to Slices/Layers to copy the selection to 
slice 2. 

The initial concentrations in these areas are to be interpolated from observed 
data.

Go to the  Maps panel and add  the map file conc_init.shp.

Associate (  Link to Parameter…) the attribute column CONC to the 
FEFLOW parameter Process Variables > Mass transport > Mass concentra-
tion by defining the link. Choose  Inverse Distance as the Data
Regionalization method and set  4 Neighbors and Exponent of  2.

Click  OK. 

On computers 
with multi-core 
CPUs or multiple 
CPUs the simula-

tion result and budget result 
may be slightly different in 
each run - even with iden-
tical input parameters. This 
is due to possibly different 
summation order when 
using parallelization.
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Double-click on CONC -> Mass concentration in the  Maps panel and 
assign the values by clicking on  Assign. 

 Clear selection. 

 exercise_fri15.fem 
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7.3 Horizontal Refinement 

Transport models typically require a finer discretization than flow models. 
For this reason, the mesh will be horizontally refined around the conta-
mination sources. 

First, the area to be refined is selected as a nodal selection. Increase the 
Snap distance to  200 m in the  Snap-Distance toolbar. Choose 

 Select by Map Polygon in the  Selection toolbar and click on 
 Select by All Map Geometries. This will select all nodes within and up 

to a distance of 200 m around the contamination sources. Hit the  Refine 
button in the  Mesh-Geometry toolbar once. 

At the transition between the refined and non-refined area, the elements 
are now quite irregularly shaped (large angles). To improve the mesh qual-
ity after manual refinement, the mesh will be smoothed in this area. Make 
sure that the  Add to Selection option in the  Selection toolbar is 
active. Define a Snap distance of  500 m and click  Select by All 
Map Geometries again in order to create a selection covering the refinement 
zone and its adjancent area. Press the  Smooth Mesh button to perform 
the smoothing. 



Constraints 

As stated before, water entering the model at the northern or southern bor-
der is fresh water. Depending on the hydraulic head distribution, however, 
at these boundaries also outflow is possible. In this case, a free outflow of 
contaminated water is to be preferred over applying a fixed concentration. 

This requires a dynamic change of the mass transport boundary condition 
depending on the flow direction, which can be implemented by applying 
a constraint. 

A constraint in our case is used to limit the mass flow at a 1st kind bound-
ary condition (fixed concentration) to a minimum or maximum value. For 
this exercise, the constraint is set to limit the mass flow to a minimum value 
of 0 g/d, applying the concentration boundary condition only for inflow-
ing water. 

The constraints are technically applied in the same way as boundary con-
ditions. However, for the sake of clarity, the constraints are not shown by 
default in the  Data panel and have to be added first: 

In the  Data panel, open the context menu of Boundary Conditions > 
Mass transport > Mass-Concentration BC and choose  Add Constraint 
> Min. mass-flow constraint. 

Expand the tree view and activate (double-click) Min. mass-flow constraint 
and assign  0 g/d to all the selected nodes with <Enter>. The mini-
mum constraint is indicated by a bar below the associated boundary con-
dition symbol. 

 Clear selection. 

Wells 

Both wells shall be operated by time-varying pumping rates. 
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 Clear selection. 

 exercise_fri16.fem 

7.4 Boundary Conditions 

Northern and southern boundaries 

Any water entering the domain through the northern or southern bound-
ary is fresh water with a concentration of 0 mg/l. Therefore a fixed con-
centration of 0 mg/l is assigned as a boundary condition at these locations. 

Go to the  Selections panel and open the context menu of the previ-
ously stored node selection Northern Boundary. Choose  Add to cur-
rent selection. 

Repeat this step with the node selection Southern Boundary. 

In the 3D view all nodes along both borders are shown as selected. Click 
on Domain in the  Entities panel. 

Double-click on Boundary Conditions > Mass Transport > Mass-Concentration 
BC in the  Data panel. In the input box of the  Editor toolbar, 
ensure that the Assign Values mode is active, input a value of  0 mg/l 
and click  Assign. 

Blue circles indicate that first kind boundary conditions are set, similar to 
the flow boundary conditions. 

11_mass_transport_I.mp4 
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7.5 Material properties 

As annual rainfall data show a significant variability during the simulated 
period, groundwater recharge is assumed to be time-varying in the model. 
The file recharge_annual.shp contains the spatial distribution of the approx-
imated recharge for annual periods each in a separate attribute field. 

Go to the Maps panel, load the map recharge_annual.shp and choose Link 
to Parameter... from its context menu. 

In the Parameter Association dialog, browse to Material Properties > Fluid 
Flow > In/Outflow on top/bottom on the right and open the context menu 
with a right-click. Choose the option Assign Material Data to Time Stages. 
The upcoming dialog lets you define the time stages for which time-vary-
ing recharge data shall be assigned (for time steps between these time stages, 
the recharge is temporally interpolated during the simulation). 

The list has to contain the same values as given in the attribute fields of the 
map (0;365;730;...). Instead of populating the list manually, the  Import... 
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Go to the menu   Edit > Time Series... and use the  Import... but-
ton to load from the pre-defined file well_rates.pow. Choose this file in the 
file selector dialog, confirm with the  Open button and  OK to 
all. Notice the gap in the time series 1: After 5200 days the western well stops 
pumping. Hit  OK for applying the time-series and closing the dialog. 

Go to the Maps panel and edit the parameter link    <multiple> -> Multilayer 
Well for the map wells.shp. by  Edit Link... Click on the link for the Rate 
and choose  Remove Link in the Parameter Association dialog. Establish 
a new link between TS_ID and Rate and set the Link Type to Time-vary-
ing (time series id). Activate the link by double-clicking on <multiple> -> 
Multilayer Well. Then click on   Select All in the  Selection toolbar.  

and  Assign in the  Editor toolbar.  

 Clear selection. 
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button lets you get those time stages automatically from the pre-defined 
file recharge_time_stages.pow. Choose this file in the file selector dialog and 
confirm with the  Open button. 

This will fill the list with annual time stage intervals up until 7300 days. 
Click  OK to close the dialog. 

The links between the attribute fields and the time stages is done the same 
way as for constant model properties. The process, however, can be accel-
erated by creating a multiple selection of all attribute fields (DAY_0 ... 
DAY_7300) before creating a link with the 0 [d] time stage. In this case, 
FEFLOW will automatically create links between all subsequent attribute 
fields and time stages (see figure). 

Click  OK to close the dialog. 

Go to the Slice view and browse to Slice 1. 

In the  Maps panel, double-click on the link entry recharge_annual > 
Linked Attributes > <multiple> -> In/Outflow on top/bottom and  Select 
All elements. Finally, set the Snap distance to  0 m and assign the val-
ues by clicking on  Assign. 

The values for the time stages have now been imported. When looking at 
In/outflow on Top/Bottom in the  Data panel, notice that a tilde sym-
bol marks the material property as time varying. 

 Clear Selection. 

Visualize the different recharge values for  time stages by right-clicking on 
In/Outflow on Top/Bottom in the  View Components panel and choos-
ing one of the entries in  Material Time in the context menu. 

 exercise_fri18.fem 

To simplify the data input of the remaining parameters, the material param-
eters effective for mass transport processes (porosity as well as longitudi-
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nal and transversal dispersivity) are assumed to be homogeneous through-
out the model. 

Go to the 3D view and activate (double click) Material Properties > Mass 
transport > Porosity in the  Data panel. 

Right-click on Material Properties > Mass Transport in the  Data panel 
and choose  Assign Multiple... from the context menu. Afterwards, 

• enter  0.2 for Porosity 

• enter  70 m for Longitudinal dispersivity  (mass) and 

• enter  7 m for Transverse dispersivity (mass) 

• Deactivate all other entries and click the  OK button to finalize 
the assignment 

 exercise_fri19.fem 

7.6 Vertical resolution 

To ensure a correct representation of low flow velocities in the aquitard as 
a basis for transport simulation, this model layer has to be further subdi-
vided.  

The best choice to minimize errors due to the nodal nature of the calcu-
lated velocity field is to apply thin layers on top and bottom of the aquitard.  

Introductory Tutorial

The two additional slices are placed within the aquitard with a distance of 
10 cm to the aquitard top and bottom.  

Go to  Edit > 3D Layer Configuration. 

Select Slice 3. Click on Insert Slice(s) Above..., type a value of  0.1 m in 
the Distance between slices input box and click  OK. 

Select Slice 2. Click on Insert Slice(s) Below..., type a value of  0.1 m in 
the Distance between slices input box and click  OK. 

The aquitard has now been divided into three layers. To ensure that the 
data are transferred correctly from the old to the new slices and layers, have 
a look at the Data Flow lists on the right of the 3D Layer Configurator. 

There are two lists that provide control over the data flow between the pre-
vious and the new slices and layers. The upper control called Data flow for 
slices describes the data flow of the process variables, boundary conditions, 
and nodal selections from the old slices to the new ones. The old slices are 
shown as number buttons in the left column, the new ones in the right col-
umn. The data flow is symbolized by lines connecting the old with the new 
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slices. The lower list, Data flow for layers describes the data flow for all mate-
rial data and for elemental selections.  

FEFLOW suggests to transfer the model properties from old slice 2 to slices 
2–4. In order to change this, double click on the number box showing 5 in 
the new column. Change this entry to  4–5. 

As a result, the link from old slice 2 points to new slices 2-3 and from old 
slice 3 to new slices 4-5. 

The data flow in the lower list for the material properties describes the same 
data characteristics from the old center layer (aquitard) to the new layers 
2, 3 and 4. No changes are necessary. 

Click on  OK to exit the 3D Layer Configurator and to apply the changes 
to the model. 

 exercise_fri20.fem 
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7.7 Simulation Run 

If working with a licensed version of FEFLOW, the results can be saved to 
a file during the simulation run. Click on  Record in the  Simulator 
toolbar. Activate  Save complete results (DAC file). By default, the results 
file (*.dac) is saved with the same name as the current model in a subdi-
rectory results. To avoid overwriting the prepared file, define another name. 
Confirm by clicking  OK. 

If running FEFLOW in demo mode, it is not possible to save the results to 
a file, and only the prepared file (exercise_fri20.fem) can be run. 

To run the model, click  Start in the  Simulator toolbar. The sim-
ulation takes approximately 5 minutes on a system with an Intel i7 pro-
cessor. 

The current simulation time is displayed in the  dropdown box of the 
 Simulator toolbar. 

Algebraic signs 
are handled dif-
ferently for 
Constraint and 

Boundary Condi tions: For 
Constraints inflows are pos-
itive (+), outflows are neg-
ative (-). For Boundary 
Conditions inflows are neg-
ative (-), outflows are posi-
tive (+).



In the Time-Steps chart (which can be opened via  View > Charts if 
not already shown) the actual time step length versus the total simulation 
time is plotted. The mostly constant conditions lead to a steadily increas-
ing time step length, with a reduced time-step whenever a change of the 
groundwater recharge occurs. 

The simulation stops after 7,300 days (the final time that has been set in 
the Problem Settings dialog before). 

Click  Stop to exit simulation mode. 

7.8 Postprocessing 

Load the recorded results file. 

 exercise_fri20.dac 
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Scene Library 

Go to the  Scene Library panel and use the context menu of the pre-
viously stored exercise_fri11:1[*] -Slice 1 item.  Create View from Scene. 
Using the  Simulator toolbar, browse through the saved time steps of 
the simulation file with the  Previous Step and  Next Step buttons, 
either step by step by single click or quickly by pressing, holding and releas-
ing the left mouse button. Due to the significant deviation of the transient 
results from the steady-state flow solution, many of the Error Bars are shown 
in red, indicating that the differential between calculated and observed val-
ues exceeds the defined confidence intervals. Finally, move to the last time 
step at 7300 [d] by using the  Last Step button and close the active Slice 
View. 



The budget shows inflows in green, outflows in red. It separates into 
boundary condition types and the internal transfer, which is in this case 
all contaminant mass crossing the border to the overlying aquitard. The 
Net value sums the positive and negative values of Total loss and gain. 
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Slice View 

Go to the remaining Slice View and double click on Process Variables > 
Mass Transport > Mass Concentration in the  Data panel. 

 Clear selection if necessary. 

The spatial distribution of the concentration at the final simulation time 
is shown. 

Use the <Pg Down> key to check the result for the lower aquifer (Slice 
5 and Slice 6).  

Subdomain Budget 

To obtain the time-integrated contaminant mass budget for the lower aqui-
fer, some additional steps are necessary: 

• Choose  Select Elements and  Select All. 

• From the context menu of the Slice view, choose  Store Current 
Selection and name the selection  Layer 5.

•  Clear selection. 

• Activate the stored selection Layer 5 in the  Selections panel by a 
single click. 

• Go to the  Subdomain Boundary Period Budget panel. 

• Click on  Add... for adding Layer 5 as Domain of Interest and switch 
to the tab Mass. 

• Check  Active and click on  S...dt to calculate the budgets for 
all time steps and accumulate them into the period budget. 
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Imbalance 

• Click on the stored selection  
Layer 5 in the  Selections panel. 

• Go to the  Subdomain Boundary Period Budget panel. 

• Click on  Add... for adding Layer 5 as  
Domain of Interest and switch to the tab Mass. 

• Check both the  Active and the  Export box and click on 
S...dt.

Accept the proposed name of the ASCII file output and proceed by hit-
ting  Save. 

Summing the mass amount of all boundaries, sources and sinks, storage 
losses and gains and internal transfers; the Imbalance shows the nume-
rical error of the mass transport for the specified subdomain over the 
entire simulation period. 

Cross Sections 

Process variables and material properties can be visualized in cross-section 
views. In our case, we are interested in the vertical distribution of the con-
tamination along the plumes. 

Cross-section display is based on lines as entities. Switch to the Slice view 
and choose  Draw a Surface (2D) Line from the  Drawing toolbar. 

Click on the sewage fields (the contamination source in the north-west) to 
define the starting point of the line here. The line is extended by adding 
points with a single mouse click. Follow the flow path to the western well 
and further to the lake Müggelsee. Finish the line with a double click. 

Repeat these steps for the waste dump (the eastern contamination source). 
The final result should look similar to the image. 

In the  Spatial Units panel, two new entries Surface Locations > 
2D Polyline #1 / #2 have been added. 

Open the context menu of 2D Polyline #1 and choose  Cross-Section 
View. 

13_mass_transport_III.mp4 
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A cross-section view showing the depth-related concentration along the 
cross-section is opened. 

In the  Navigation panel, go to the Projection tab and push up the lever 
to exaggerate the z-axis. 

Isosurfaces 

Go to the 3D view. Make sure that Domain is selected in the  Entities 
panel. In the  Data panel, double-click on Mass concentration to show 
this parameter in the view. In the  View Components panel, uncheck 

 Faces and Mass concentration >  Continuous. Check Mass concentra-
tion > Isosurfaces >  Domain. Instead, one isosurface is shown.  

To edit the isosurface visualization properties, double-click on Isosurfaces. 
The  Properties panel comes to front. Switch to the  Custom mode and 
click on  Edit. Specify two values,   10 mg/l and  20 mg/l. Close the dia-
log by clicking  OK, and click  Apply in the  Properties panel. The isosur-
face visualization is changed to reflect the newly set concentrations. 

Breakthrough Curves 

Open from the menu  View > Charts > Local Concentration History. The 
diagram shown contains the concentrations calculated at the different 
observation points during the simulation time.

More Information 
This completes the dintroductory tutorial, that gives an overview of the 
basic functionality and workflows of FEFLOW. 

Additional tutorials, application examples and  more detailed descripti-
ons of the program features are provided by the FEFLOW help  . 

For more information, including extensions, tutorial videos, user forum 
and more, please visit 

www.feflow.com
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